小さな画面でのAndroidの互換性の問題

LGE P-350、ZTE Kyivstar Shine(racer2)、Samsung Galaxy Miniなど、一部のデバイスとの互換性に関する私のAndroidプロジェクトに関する問題があります。これらのデバイスはサポートされていません。

編集アプリケーションのapkファイルの横には、次のような記述があります。

APIレベル:7-16 +サポートされる画面:small-xlarge OpenGLテクスチャ:すべて

サポートされているデバイスのリストには、これらのデバイスは互換性がありませんが、それ以上の情報はありません。

これらのデバイスはAPI 8以上をサポートしているため、問題ではありません。

サポートされている画面にはsmall-xlargeと表示されます。私は小さな "sceen"サイズよりも小さいことがわかったので、なぜそれが問題になるのかわかりません。問題のあるデバイスは、しかし、画面サイズ/密度が小さい。 resでは多くのレイアウトがあり、ほとんどの描画可能ファイルは-mdpi -ldpiと-hdpiフォルダにあり、小さな画面に最適化されています。

私は次のように試してみたが、問題は解決されなかった。


私のプロジェクトではgoogle maps libaryとandroid-mapviewballoonsも使用していますが、なぜそれが問題になるのかわかりませんが、ここではそれを書いています。

アイデアがなくなったので、以下のリンクで解決策を探しましたが、これまでのところ運がありません。何が間違っているかについてのいくつかのアイデアは本当に役に立ちます。

http://developer.android.com/guide/practices/compatibility.html

http://developer.android.com/guide/practices/screens_support.html

ありがとう、 ゾルタン

1
サポート画面を削除し、代わりに互換性のある画面を使用してすべての組み合わせを列挙した場合は役立ちますか?次に、 developer.android.com/guide/practices/screens-distributionの例を示します。 h‌ tml
追加された 著者 VJ Vélan Solutions,
あなたはを試してみましたか?
追加された 著者 BitBank,
はい、私は持っている、それは元の投稿に書かれています。
追加された 著者 ZoltanT,
こんにちは、お返事ありがとうございました。残念ながら、あなたの提案は私のためには機能しません。なぜなら、それはAPIレベル9+で利用できるからです。私は7を使用しており、もっと上がる余裕がありません。
追加された 著者 ZoltanT,
実際には、SDKからこれらのデバイスにアプリケーションをインストールすることもできて、問題なくスムーズに実行できるというのは本当に面倒です。一体何が起こっているの?
追加された 著者 ZoltanT,

1 答え

これを追加してみてください:


Galaxy Miniはオートフォーカスをサポートしていないようだ。多分他の人もそうではないでしょう。

1
追加された