EclipseでAndroidのバージョンを設定する方法は?

私はAndroid用の最初のアプリをEclipseで作成しました。私はそれを公開したが、私はそれがAndroidの最小バージョンがサポートされて表示されていないことをアプリページで気づいている、あなたはそれをここに見ることができます:

https://market.android.com/details?id=com.yellowhouse.everydayquotes

私はプロジェクトファイルを検索しました。私はproject.propertiesに次の行があることを発見しました:

target = android-15

それはAndroid版を設定するための正しい場所ですか?何か不足していますか?ページに表示されないのはなぜですか?ありがとう。

0
マニフェストに minSdkVersion 属性を追加する必要があります。
追加された 著者 Mudassir,

2 答え

あなたのアプリに最低限必要なアンドロイドバージョンを設定するには、AndroidManifest.xmlファイルの中で uses-sdk 要素を使用する必要があります:


    
    ...

Version 4 means Android 1.6. Read up information on android manifest to see the correct sdk version numbers: http://developer.android.com/guide/topics/manifest/uses-sdk-element.html

1
追加された

あなたが持っている "target = android-15"はあなたのアプリを起動させたいあなたのエミュレータまたはテストデバイス用です

あなたの質問に答えるには、あなたのアンドロイドマニフェストファイルでminSDKのバージョンを設定する必要があります そのような


     


1
追加された