VS2010はMicrosoft.VisualBasicの依存関係について不平を言います

VS2008からVS2010にアップグレードしたばかりの.NETソリューションがあります。 3つのWebプロジェクトと2つのストレートVBプロジェクトが含まれています。 Webプロジェクトはすべて、BusinessLogicと呼ばれるVBプロジェクトの1つに依存しています(参照しています)。

すべてのプロジェクトは.NET 2.0を対象としていますが、VS2010では以下のビルド警告が発生しています。

次のアセンブリは.NETのバージョンに依存しています   ターゲットよりも高く正しくロードされないフレームワーク   実行時に障害が発生する:BusinessLogic、   バージョン= 1.0.4419.22315、Culture =ニュートラル、PublicKeyToken = null。ザ   依存関係:Microsoft.VisualBasic、バージョン= 8.0.0.0、   文化=ニュートラル、PublicKeyToken = b03f5f7f11d50a3a。あなたはどちらか   依存するアセンブリがターゲットに対して正しいことを確認します   フレームワークを使用したり、対象とするフレームワークが   依存するアセンブリのものです。

私の知る限り、8.0.0.0は.NET 2.0用のVBの正しいバージョンです、なぜこれが警告ですか?これは心配するものですか?

4

1 答え

プロジェクト|プロパティのメニューに行き、 "References"タブをチェックしなければなりません。 使用する参照が.NET 2.0以上であることを確認します。

0
追加された