Gaelyk Eclipse構成エラー

私はテンプレートプロジェクトのgradleスクリプトを使ってeclipseでgaelykプロジェクトを設定しようとしましたが、常に失敗しました。 これを行うには次のコマンドを使用します: gradlewきれいなEclipse Eclipse

すべてのパッケージが正しくダウンロードされているように見えますが、.projectと.classpathファイルが作成されますが、私はいつもこのエラーをプロジェクトに書いています:

The App Engine SDK 'C:\Users\username\.gradle\caches\artifacts\com.google.appengine\appengine-api-1.0-sdk\c12498cf18507aa6433a94eb7d3e77d5\jars\appengine-api-1.0-sdk-1.6.1.jar' on the project's build path is not valid
(SDK location 'C:\Users\username\.gradle\caches\artifacts\com.google.appengine\appengine-api-1.0-sdk\c12498cf18507aa6433a94eb7d3e77d5\jars\appengine-api-1.0-sdk-1.6.1.jar' is not a directory)

Appengine SDKが.classpath/.projectファイルで正しく指定されていないようです。 私は日食のインディゴと日食のためのGoogleのプラグインの最後のバージョンをインストールしました

どうすれば修正できますか?

0
私はあなたが gradlew cleanEclipse eclipse を意味すると思います。 Googleのプラグインは何ですか?あなたがSTS Gradleプラグインを意味する場合、それは gralew cleanEclipse 代替です。
追加された 著者 Peter Niederwieser,
私はGaelykの開発者に尋ねることをお勧めします。 Gradleビルドで生成されたEclipseプロジェクトがGoogleプラグインと一緒に使用されるかどうかは不明です。
追加された 著者 Peter Niederwieser,
うん!コマンドはそれです:私は明確にするために質問を編集しています。プラグインはeclipse用のGoogleプラグインです: code.google.com/eclipse
追加された 著者 pbanfi,

1 答え

私は個人的にGaelykの開発にEclipseを使用していません。したがって、テンプレートプロジェクトのGradleビルドスクリプトの既存のEclipse設定がGoogleプラグインで機能するかどうかはわかりません。

しかし、しばらく前にGradle GAEプラグインのプルリクエストを受けましたEclipseプラグインと統合する。私はそれがあまりにも具体的で、Googleの設定が変わるかもしれないので、潜在的にGradleプラグインに多くのバグにつながるので、それを無効にしていました。 作成者は、別のプラグインを作成してpingを試みる予定でした。

また、ここで役立つ Gradle Plugin についても知っています。 Gaelykメーリングリストに質問を投稿してみてください。

1
追加された