XSDファイルを変更するときのエラーメッセージ

私はxsdファイルを持っており、スキーマは以下のようになります。


  
     ****
  

XYZ要素に属性use = requiredを追加したい場合は、どのような問題がありますか。私はいつも次のエラーを受け取ります - 'use'属性は許されません。

よろしく

0
私は排除のプロセスを使用したいと思います。これ以上エラーが発生しなくなるまで、子ノードの削除を開始します。あなたはXSDを読み書きしようとしていますか?
追加された 著者 MacGyver,
私は既存のxsdファイルを変更しようとしています。これは、XYZ要素がxmlファイルに常に指定されていることを確認するためです。
追加された 著者 Dexter,

1 答え

xs:elementのminOccursおよびmaxOccurs属性を使用して、最小および最大の出現回数を指定します。デフォルトはminOccurs = "1"、maxOccurs = "1"です。

PS。あなたが推測しているかのように見えます。 XSDを使用すると、推測はあなたを非常に遠くにさせることはありません。言語を使用して何年も後、私はまだ私の側で参考書が必要です。

1
追加された