Perlとgkt2で動作するWebKitバインディングの取得

私はperl + gtk2アプリケーションでWebKitを使用する必要があります。 CPANでGtk2 :: WebKitパッケージを見つけましたが、それを動作させることはできません。

cpan> install Gtk2::WebKit

次の出力が得られます。

Package webkit-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `webkit-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'webkit-1.0' found
at inc/Module/Install/PRIVATE/WebKit.pm line 24
*** can not find package webkit-1.0
*** check that it is properly installed and available in PKG_CONFIG_PATH
at inc/Module/Install/PRIVATE/WebKit.pm line 24
No 'Makefile' created'YAML' not installed, will not store persistent state
FLORA/Gtk2-WebKit-0.09.tar.gz
/usr/bin/perl Makefile.PL INSTALLDIRS=site -- NOT OK
Running make test
Make had some problems, won't test
Running make install
Make had some problems, won't install
Failed during this command:
FLORA/Gtk2-WebKit-0.09.tar.gz                : writemakefile NO -- No 'Makefile' created

cpanがWebkitを見つけることができなかったかのように見えますが、私はそれを修正する方法がわかりません(初めてperlとcpanを使用しています)。

Env:perl 5.12.4、ubuntu 11.10

2

3 答え

libwebkitgtk-devel をインストールします。 sudo apt-get install libwebkitgtk-devel

6
追加された
それは私の問題を解決した、ありがとう
追加された 著者 Karol Buczel,

sudo apt-get install libwebkitgtk-dev

5
追加された

Debian/Ubuntuなどの場合、インストールするパッケージ名は libwebkitgtk-dev です。 OpenSuseや他のRPMベースのシステムでは、パッケージ名は libwebkitgtk-devel です。

3
追加された
JavaScript - 日本のコミュニティ
JavaScript - 日本のコミュニティ
2 参加者の

日本人コミュニティのjavascript