デフォルト情報のためのCiscoルートマップオブジェクトトラッキング

特定のIPアドレスがICMP到達可能である場合にのみ、RIPを使用して既定のルートを条件付きでアドバタイズするように任されています。 (はい、実際のネットワーク設計ではなく、CCIEスタディ)。

私の考えは、

R1#show run | s route-map|sla|track|router rip
track 1 ip sla 1
router rip
 version 2
 network 150.1.0.0
 network 155.1.0.0
 default-information originate route-map RELIABLE_DEFAULT
 no auto-summary
ip sla 1
 icmp-echo 155.1.7.7
 frequency 5
ip sla schedule 1 life forever start-time now
route-map RELIABLE_DEFAULT permit 10
 match track  1

トラックオブジェクトとSLAは実際に正常に動作しており、ルートマップはトラックオブジェクトに登録されています。

R1#show ip sla summary 
IPSLAs Latest Operation Summary
Codes: * active, ^ inactive, ~ pending

ID           Type        Destination       Stats       Return      Last
                                           (ms)        Code        Run 
-----------------------------------------------------------------------
*1           icmp-echo   155.1.7.7         RTT=12      OK          0 seconds ago                                                                  

R1#show track 1
Track 1
  IP SLA 1 state
  State is Up
    2 changes, last change 00:08:55
  Latest operation return code: OK
  Latest RTT (millisecs) 12
  Tracked by:
    Route Map 0

しかし、これは動作しません(デフォルトルートは広告されません)。好ましい解決策は、このように実際に働いているダミーのスタティックルートを使用することです。

ip sla 1
 frequency 5
 icmp-echo 155.1.7.7
ip sla schedule 1 start-time now life forever
track 1 ip sla 1
! 
ip route 169.254.0.1 255.255.255.255 Null0 track 1
!
ip prefix-list DUMMY_ROUTE seq 5 permit 169.254.0.1/32
!
route-map RELIABLE_DEFAULT permit 10
 match ip address prefix-list DUMMY_ROUTE
! 
router rip
 default-information originate route-map RELIABLE_DEFAULT

私はこのソリューションがなぜ機能するのか理解していますが、なぜ私が理解していないのか分かりません。何か案は?

0
まあ、waza-ari、それを得た人、誰でも? IP SLAで偽のIPアドレスのハックを使用する方法を理解するのが難しいと私が指摘した回答(EEM)またはOzNetNerdのコメントsupportforums.cisco.com
追加された 著者 Ron Royston,

2 答え

私は試験についてはわかりませんが、現実の世界では、このようなことは Cisco iOS Embeddedイベントマネージャ(EEM)を参照してください。

See Also EEM script to report routing table change

event manager applet route-table-monitor

 event routing network 0.0.0.0/0 ge 1

 action 1.0 syslog msg "Route changed: Type: $_routing_type, Network: $_routing_network, Mask/Prefix: $_routing_mask, Protocol: $_routing_protocol, GW: $_routing_lastgateway, Intf: $_routing_lastinterface" 
3
追加された
あなたがメールを処理しなければならないように、手掛かりを持っている人は誰でもSNMPトラップを処理しています。もしそうでなければ、彼らはこの不条理なスレッドで言及された理由だけでなく、トラップレシーバを設定する必要があります
追加された 著者 Mun,
ああ、実際に、EEMは外部サーバーなしでどのように通知するのですか? EEMがsyslogサーバーなしで警告したことをどのくらい正確に知っていますか?
追加された 著者 Mun,
iOS Release 12.4T :Enhanced Object Tracking(EOT)がEEM(Embedded Event Manager)に統合されました。追跡されたオブジェクトの状態変化とEOTがEEMオブジェクトを追跡することを可能にする。
追加された 著者 Ron Royston,
警告するには、はい。条件付きで経路を注入することはできません。私はそれができると思うが。 SNMP v1と2に関するセキュリティ上の問題がありました。私はv3がそれを修正すると思う。
追加された 著者 Ron Royston,
SNMPはこれには使用されません。それを見たことはありません。それは可能かもしれないが、私はそれが完了したことを見たことがない。 EEM私はたくさんのものを見た。
追加された 著者 Ron Royston,
SNMP?あなたはEEMを意味しますか?私は、EEMが、より多くの機能を持つことに加えて、「偽のIPアドレス」ハックを使用するよりも、スクリプトや理解が容易だと思います。あなたは?
追加された 著者 Ron Royston,
そうですか。私はそれができると思う? EEMは、外部の管理サーバーなしで通知を行います...改善と非常にクールな機能。
追加された 著者 Ron Royston,
現実の世界では、プライマリWANリンクの停止を通知したいと思います。 EEMはメールで自動通知できます。
追加された 著者 Ron Royston,
EEMはより多くの機能を提供します。だから私たちはそれを使用しています。
追加された 著者 Ron Royston,
@MikePennington私は "外部管理サーバー"と述べた。 EEMスクリプトでメールサーバーを指定する必要があります。 こちらをご覧ください。 SNMPの電子メールアラートはSNMPのサーバーの権利から来るでしょうか?
追加された 著者 Ron Royston,
Downvoterはフィードバックを提供することはできませんか?それとも、居住者のトロールがこのサイトをもう一度破壊するのだろう...私はダウンダウン者がEEMについて聞いたことがないと確信している。
追加された 著者 Ron Royston,
@MikePennington人々は、ネットワーク管理サーバーと電子メールサーバーで電子メールでSNMPトラップを処理します。または、私はあなたを誤解しましたか?私はあなたのフィードバックに感謝しますが、なぜあなたはこのスレッドを不条理として特徴づけていますか?それは失礼です。 「あなたがメールを処理しなければならないように、すでに手掛かりを持っている人はSNMPトラップを処理している人は誰も間違っています。私は皆さんに教えてもらえますが、何かもっと私は請求するつもりです。私に直接メールしてください。
追加された 著者 Ron Royston,
私はマイクに同意する。このスレッド/これらのコメントは、必要以上に長くなっています。私が数回言及したように、問題をどのように解決したいかを決めるために、それをOPに任せましょう。単一の中央管理サーバーを使用するのではなく、個々の個々のデバイスにEEMスクリプトを実装することについては、それはあなたの選択ですが、私がITにいてもそのように見られることはありませんでした。とにかく、OPの質問がずっと前に答え​​られたと感じるので、これはこのスレッドの最後の投稿になります。
追加された 著者 William S. Godfrey- S.E.,
私は、SNMPを使ってルートを注入できるとは言っていませんでした。上記の会話をもう一度読んでください。あなたはEEMを使用して警告を出したところで、SNMPをアップしたところで話しました。
追加された 著者 William S. Godfrey- S.E.,
リンクダウンイベントを警告する監視アプリケーションと一緒にSNMPを使用したことはありませんか?それは非常に一般的です。私が知っているすべてのエンジニアは、既にソリューションを導入していない場合、それを使用して顧客のためにセットアップします。
追加された 著者 William S. Godfrey- S.E.,
いいえ、私はSNMPを意味しました。偽のIPを使用するのは奇妙ですが、自分のスクリプトを書くよりもシスコ自身のコマンドを使用する方が良いでしょう。他の誰かがルータで作業する必要がある場合は、シスコのマニュアルを参照して、コマンドの動作を確認してください。しかし、あなたが独自のスクリプトを書くと、同じ贅沢はありません。とにかく、前に述べたように、彼らがそれをやりたいと思う方法を決めるためにそれをOPに任せましょう。
追加された 著者 William S. Godfrey- S.E.,
SNMPも同様です。 Ciscoによって提供され、無制限の有料、無料、オープンソースの監視アプリケーションによってサポートされるもう1つの機能。前述のように、私は車輪を再開発するのではなく、シスコ(および他のベンダー)が提供する機能を使用することを好みます。
追加された 著者 William S. Godfrey- S.E.,
確かにそれはより多くの機能をサポートしていますが、余分な機能を必要としない場合は何かカスタムを書くのはなぜですか?それはあなたが必要とするすべてが家族の車であるときにバスを買うようなものです。確かに、それはより多くの人々を座らせることができますが、それはなぜですか?私は物事を簡単に保つことを好む。トラブルシューティングが容易になります。さらに、PythonスクリプトはEEMよりもさらに多くの機能を提供します。 EEMと同じように私はやっていましたが、なぜそれが示唆されなかったのかは、手元にある仕事にとっては残酷です。
追加された 著者 William S. Godfrey- S.E.,
シスコ自身が必要なコマンドを提供しているときに、スクリプトを書くのはなぜですか?
追加された 著者 William S. Godfrey- S.E.,

おそらく、デフォルトの情報発信コマンドはIP SLAと互換性がありません。

おそらくこれは既に見てきましたが、このシスコのフォーラムでは、偽のスタティックルートを使用する方法について説明しています。

https://supportforums.cisco.com/document/116336/ospf -reliable-conditional-default-routing

この方法を使用すると、デフォルトの情報発信コマンドがIP SLAと直接インターフェイスしていないことを意味します。

3
追加された
あなたの例はRIPを使用していません。デフォルトの情報はIP SLAではなくルーティングプロトコルに関連しています。右? RIPに固有の例を見つけることが難しい理由は、RIPがOSPF/EIGRPと比較して実世界で使用されることはめったにないからです。 EEMではコードをスクリプト化できるので、IOSがサポートしているものと互換性があります。
追加された 著者 Ron Royston,
追加された 著者 Ron Royston,
公正であるために、私は間違った技術を言ってはいけません。それは、EEMが非常に機能豊富で、これが最近使用されていると見られていることです。
追加された 著者 Ron Royston,
それは単なるGoogleの検索であり、私が提供したような特定の参考文献ではありません。一日の終わりに彼らはそれをどのように行うのか?前述のように、私は独自のスクリプトを書くのではなく、シスコが提供するコマンドを使用することをお勧めします。なぜホイールを再発明しようとしますか?
追加された 著者 William S. Godfrey- S.E.,
私はEEMスクリプトを書く方法を知っています。私が意味していたのは、このシナリオでEEMを使用している他の人たちを示す参考資料がありますか?あなたがそれがより良い方法であることを示唆していることを彼らの多くが与えられるはずです。
追加された 著者 William S. Godfrey- S.E.,
なぜそれは間違った技術ですか?それは動作し、私も参照リンクを掲載投稿した。 EEMの提案にも同じことをしていただけますか?
追加された 著者 William S. Godfrey- S.E.,