cygwinでBjamをコンパイルする方法

私はcygwinでブーストを構築しようとしていますが、私はコンパイルを開始するbjamを得る方法を見つけることができません。私は何かを逃しているかもしれません。誰か私に手がかりを与えることができますか?参考:次のエラーメッセージが表示されます。

$ bjam --without-python --without-serialization toolset=gcc-android4.4.3 link=s
tatic runtime-link=static target-os=linux --stagedir=android
warning: mismatched versions of Boost.Build engine and core
warning: Boost.Build engine (bjam) is 03.1.18
warning: Boost.Build core (at /cygdrive/c/progra~1/android/android-ndk-r6b/sourc
es/boost/tools/build/v2) is 2011.04-svn
/cygdrive/c/progra~1/android/android-ndk-r6b/sources/boost/tools/build/v2/util/p
ath.jam:476: in path.makedirs
rule MAKEDIR unknown in module path.
/cygdrive/c/progra~1/android/android-ndk-r6b/sources/boost/tools/build/v2/build/
configure.jam:190: in configure.set-log-file
/cygdrive/c/progra~1/android/android-ndk-r6b/sources/boost/tools/build/v2/build-
system.jam:725: in load
/cygdrive/c/progra~1/android/android-ndk-r6b/sources/boost/tools/build/v2/kernel
/modules.jam:283: in import
/cygdrive/c/progra~1/android/android-ndk-r6b/sources/boost/tools/build/v2/kernel
/bootstrap.jam:142: in boost-build
/cygdrive/c/progra~1/android/android-ndk-r6b/sources/boost/boost-build.jam:17: i
n module scope

更新:これは私のシステムパスの1つに置かれた古いbjam.exeの問題でした。右のbjamを使用した後、問題はなくなりました。

0
Miserable Bjamコマンドが見つかりません。私は現在gccをインストールするcygwinをアップデートしています。
追加された 著者 Tae-Sung Shin,
これまでに何を試しましたか?あなたの手続きとすべてのエラーを投稿してください。
追加された 著者 thiton,
そして確かに、出力の最初の行はBoost.Buildエンジンのバージョンが間違っていることを示しています。
追加された 著者 Vladimir Prus,

答えはありません

0