Django1.3はPython 2.7.2をサポートしていますか?

私は私のサーバーをアップグレードする計画がある。私の主要な要件は、Python django1.3とpostgres8.4です 私はDjango 1.3とPython 2.6.5を現在使用しています。サーバーをアップグレードしたいので、django 1.3がPython 2.7.2をサポートしているかどうかを知りたいですか? 11.04にはPython 2.7.1が付属し、11.10には2.7.2が付属しています。

私はdjango 1.3が2.4から2.7をサポートしていることを知っていますか?私はサーバー上でリスクを冒したくないので、django 1.3がPython 2.7.1または2.7.2、またはその両方をサポートしているかどうかを知りたいと思っています。 どうすれば仮想環境をインストールできたのかを指定してください。複数のバージョンのdjangoとpythonを持っていて、django.core.managementという名前のモジュールはありません。

前もって感謝します

0

2 答え

DjangoはPython 2.7のすべてのバージョンをサポートしています。 2.7.1と2.7.2は2.7のマイナーバージョンであるため、Djangoはそれらと連携します。

3
追加された

私たちはDjango 1.3とPython 2.7.2をかなりの期間使用しており、互換性の問題に直面していません。

複数のバージョンのPythonをインストールしたい場合は、pythonbrew(https://github.com/utahta/pythonbrew)のようなツールを使用する方がよいでしょう。

"No module django.core.management"というエラーに関しては、他のバージョンのPythonでdjangoをインストールしている可能性があります。もう一度、プロジェクトディレクトリのどこかに仮想envを作成して(見つけやすくなるように)仮想環境を作成してください。また、pythonbrewを使用して仮想環境を管理する方がよいでしょう。

1
追加された