EE 1からEE 2への更新時に「エラーを返さずに更新スクリプトが失敗しました」という漠然としたエラー

私が更新プログラムを実行すると、2.0.0になるとすぐに失敗するこのエラーが発生します。 exp_commentsテーブルを更新すると、スクリプトは停止します。私は$ conf ['allow_extensions'] = "n"を設定しようとしました。更新を実行する前に何もしなかった。

私は正常にEE 1.6から1.7.3に更新しました。現在、私が更新しているバージョンはEE 1.7.3です

Image of error screen

1
ネイト、最初に2.3に更新しようとしましたが、まだ運がありません。
追加された 著者 Lea Cohen,
EEの以前のバージョンに更新してみてください。例えば、2.6またはそれ以前。その後、2.7.3に行く(私は知っている、二重の仕事が、2.x.xになることは重要な部分ですが、そこから上がっていきます)。
追加された 著者 Rodrigo Sieiro,

1 答え

2にアップグレードする前に1を更新する必要はありません。これはCargo Cultのブードーです。

このエラーは、third_partyアップデートルーチン(多くの場合)を実行しようとしているインストーラに固有です。一時的にthird_partyを削除し、再度インストーラを試してください。

2
追加された
私は1対173を更新することは何の違いもないと思っていたが、私は考えることができるすべてを試していた。 third_partyを削除することをおすすめしますか? EE1には「third_party」フォルダはありません。アップデートを実行する前にconfig.phpに入れなければならない設定オーバーライドはありますか?
追加された 著者 Lea Cohen,