Catch 22、SDKおよびAVD ManagerにはSDKの場所が必要ですが、SDKの場所にはADTのアップデートが必要ですか?

だから私はちょうどEclipseのSDKとAVDマネージャを使って何らかのアップデートを試みた。私はちょうどすべてをクリックしてアップデートをインストールしたと思う。私はこれをインストールした後、Eclipseを再起動しましたが、再度起動すると、ADTを最新バージョン(14.00)に更新する必要があり、私のバージョンが12.00であるというエラーメッセージが表示されます。

しかし、ADTを更新するためにSDKとAVDマネージャに移動しようとすると、 Android SDKの場所が環境設定で設定されていません

それで、私が設定に行き、SDKの場所を見ると、このAndroid SDKはAndroid Developer Toolkitバージョン14.0.0以上が必要です。現在のバージョンは12.0.0.v201106281929-138431です。 ADTを最新バージョンに更新してください。

何とか手動でSDKを更新する必要がありますか?私は本当にここで何が起こったのか分かりません。助けを前にありがとう。

0
だから私は完全にEclipseとADTをアンインストールし、再インストールする必要があるかもしれないと示唆している?それはとても乱雑に聞こえる。
追加された 著者 wfbarksdale,
さて、あなたは正しい方向を指しているようです、ありがとう、笑
追加された 著者 wfbarksdale,
追加された 著者 Ken White,
私は何も示唆しなかった。 :)私はちょうど同じ問題に対処するように思われた別の質問を指摘しました。
追加された 著者 Ken White,

1 答え

私は最近この問題を抱えていました。私はADT、SDK、ツール、すべてを完全に削除してから、再インストールして更新しました。私はEclipseを削除する必要はありませんでした。

編集:

Here is a link to the AVD revision information site. If you look at the different versions, it will tell you the required SDK tools version. When this happened to me, I remember it saying something like "if you have less than version 14 then you must update manually" ... but I was unable to find it.

Here is a link to the SDK tools revision information site.

1
追加された
奇妙なので、アップデータには問題があります。あなたがGoogleに質問を提出するために使うことができるボタンがあれば、それが原因で何が起こっているか把握することができれば涼しいでしょう。
追加された 著者 wfbarksdale,