NVM(Ubuntu)を使用して複数のバージョンのnode.jsをインストールする

NVM を使ってUbuntuに複数のバージョンのnode.jsをインストールするには?

31
これはUbuntuではうまくいかないので、@racarはこれが好きではない!
追加された 著者 Alfred,
追加された 著者 malletjo,

3 答え

事前知識

端末の使い方たとえば、 gnome-terminal を使用できます。

依存関係をインストールする

sudo apt-get install build-essential libssl-dev curl git-core

NVMのインストール

Below we will NVMのインストール.

nvmのダウンロード

git clone git://github.com/creationix/nvm.git ~/.nvm

nvmを起動するには、bashシェルからソースを取得する必要があります

echo "\n. ~/.nvm/nvm.sh" >> .bashrc

node.jsのバージョンをインストールする

この例では、ノードv0.4.12をインストールします。まず、新しいbashセッションを開く必要があります。もう一度 bash と打つことでこれを行うこともできます。

$ bash
$ nvm install v0.4.12 #This takes a while.

最新のv0.4ブランチをデフォルトにするには

$ nvm alias default 0.4

トラブルシューティング

すべての依存関係がインストールされていないと、node.jsをコンパイル/インストールできません。その後、〜/ .nvmをクリーンアップする必要があります

$ rm -rf ~/.nvm/
71
追加された
そのエコーラインは私にUbuntu 12.04に関するいくつかの問題を引き起こしました。ファイルを編集して source〜/ .nvm/nvm.sh に変更しなければなりませんでした。
追加された 著者 jcollum,

一番上の答えは古いです。今、インストールするgithubのガイドに従ってください:

https://github.com/creationix/nvm#installation

Linuxマシンの場合、次のように簡単です:

curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.31.0/install.sh | bash

4
追加された