EngineYard Jrubyのインスタンスを1.9.2にデフォルト設定する

私はEngineyardのJrubyでテストしようとしているRailsアプリケーションを持っています。私はrvmのRubyバージョンを1.9.2(jruby)に切り替えるとローカルで動作するようになることができます。ただし、エンジンヤードでデプロイが失敗すると、

syntax error, unexpected ':'

1.9.2 export JRUBY_OPTS = - 1.9 を使ってこのエラーをローカルで解決しました。これはengineayrdで試しましたが、私はまだ同じエラーが発生しています。

誰かが、Ruby-1.8.7-p330ではなくEngineYardを1.9.2にデフォルト設定する方法を知っていますか?

どんな助けでも大いに感謝しています

1
追加された
ビュー: 1

1 答え

/home/deploy/.jrubyrcに次の行を入れてみてください。

compat.version=1.9
1
追加された
そのファイルはそのディレクトリにありませんか?
追加された 著者 Charlie Davies,
しかし、私はtrinidad_configを見つけましたが、上記の行を追加しても違いはありませんでした。それを有効にするためにインスタンスを再起動する必要がないかぎり?
追加された 著者 Charlie Davies,
ああ、働いた。私は今、SQLエラーを取得していますが、私はそこに着いています。ご協力いただきありがとうございます。
追加された 著者 Charlie Davies,
申し訳ありませんが、ファイルを作成し、その行を挿入します。
追加された 著者 Nick Sieger,