Eclipseで既存のAndroidプロジェクトをインポートする

既存のAndroidプロジェクトをインポートしようとすると、Eclipseからエラーが表示されます。

Android requires compiler compliance level 5.0 or 6.0. Found '1.4' instead. Please use Android Tools > Fix Project Properties.

私はプロパティを修正し、コンパイラレベルも1.6に設定しました。しかし、私はまだ同じエラーが発生しています。今私は何をすべきですか?

2
1.6 JDKをインストールしましたか?
追加された 著者 bakoyaro,
初心者の方:Android Toolsのプロジェクト名を右クリックすると、プロジェクトプロパティの修正が見つかります。
追加された 著者 Martin,

3 答え

次の手順を試してください。私はEclipse Indigoを使って今日働くことができました

Create New Workspace -> Open SDK Manager -> Update the SDK -> restart the eclipse -> Import the project to this workspace -> right click on Project -> Android Tools -> Fix Project properties -> restart Eclipse

2
追加された
それは動作しますが、それはPITAであり、開発環境がそれ自身を "修正"するべきものです。
追加された 著者 Someone Somewhere,

私にとっては、EclipseやADTのバグと思われるものがありました。この問題は、ワークスペースの作成場所によって異なります。

このような構造のworkspace \ projectでは、問題は発生しませんでした。
この問題は、workspace \ somesubfolder \ projectのような構造になったときに表示されました。

プロジェクト固有の設定(これはフィックスプロパティが何をするかを指定する)は、そのバグを回避するように思われ、とにかく良い方法かもしれません。

2
追加された

Doing Project -> Clean... fixed it for me.

私のEclipseは動作を停止していたので、 workspace ディレクトリを消去し、プロジェクトをインポートするときにEclipseを実行した後、この問題が発生しました。ここに示唆された他の解決法はうまくいかなかった

1
追加された