HTML5のボイラープレートでIE7/8の予期しないオブジェクトエラーが発生する

I am using HTML5 Boilerplate on a project. Unfortunately I am getting these SCRIPT438 errors in IE 7/8 which prevents my jQuery from running. The dev site is here http://clintongreen.com/clients/researchreview/index.html

**ERRORS**
SCRIPT438: Object doesn't support property or method 'hoverIntent' 
plugins.js, line 47 character 5
SCRIPT438: Object doesn't support property or method 'accordionza' 
script.js, line 31 character 2
SCRIPT438: Object doesn't support property or method 'nivoSlider' 
script.js, line 3 character 5

できるなら助けてください、これは本当に私を悩ましています、ありがとう

1
jqueryの競合を試しましたか?
追加された 著者 Val,
こんにちは、申し訳ありませんが、疑問の言い訳を申し訳ありませんが、私は矛盾のないスクリプトを追加する必要があります。Boilerplateは1ページにすべてのスクリプトを持っていますので、ページの上部に追加しようとしましたが、無紛争。ありがとう
追加された 著者 Clinton Green,
いくつかの作業の後、2つのエラーが発生しました。SCRIPT438:オブジェクトはプロパティまたはメソッド 'hoverIntent' plugins.js、行47文字をサポートしません5 SCRIPT438:オブジェクトがプロパティまたはメソッド 'nivoSlider' script.js、lineをサポートしません3文字5、しかし私はまだ紛争で動作するようにティを得ることができません:(
追加された 著者 Clinton Green,
OKそれを解決しました、それはすべての正しい方法を注文のちょうどケースでした。
追加された 著者 Clinton Green,

1 答え

SCRIPT438のこの定期的な問題を持っている皆のために:オブジェクトはIEの古いバージョンでプロパティやメソッド 'BlahBlahBlah'をサポートしていませんが、現代のブラウザではすべて正常に動作します。

ここで問題となっていたのは、現代のブラウザがスクリプト全体を読むように見えてから、何を持っていくのかがわかるようなスタック順序です。古いブラウザでは、一行ずつ読むようです。

だから私はすべての私のプラグインのための長いjsページを持っていた、そして、私は一番下に追加された他のプラグインのいくつかはjQuery UIに依存したので、それはエラーを与えた。すべてを正しい順序に変更すると、すべて正常に機能しました。乾杯

2
追加された